(redirected from Programming.Chocolatey)

 

 

A Delicious tool working with NuGet

 

Scott Hanselmann: Is the Windows user ready for apt-get?

 

Home: http://chocolatey.org (if this is down, try the backup at http://chocolatey.apphb.com )
Forum: http://groups.google.com/group/chocolatey
Twitter: http://twitter.com/chocolateynuget

 

https://github.com/chocolatey/chocolatey/wiki
https://github.com/chocolatey/chocolatey

 

Commands Reference

 

 

Installation (from chocolatey.org)

regular shell

 

powershell

iex ((new-object net.webclient).DownloadString('https://chocolatey.org/install.ps1'))

 

notes

See chocolatey-installation for more notes.

 

update

chocolatey update or cup
See https://github.com/chocolatey/chocolatey/wiki/CommandsUpdate

 

 

managing packages

Installing packages

Install syntax is cinst packageName

 

uninstalling packages

The uninstall syntax is chocolatey uninstall packageName or just cuninst packageName

 

You can optionally uninstall a specific version: cuninst packageName -version 1.0.1234

 

See Rob’s link for the latest, including known limitations: https://github.com/chocolatey/chocolatey/wiki/CommandsUninstall

 

list installed packages

cver all -localonly or -lo - tells you whether they are up-to-date, so there is a round-trip involved
choco list -lo or clist -lo

 

Incompatible Schema error

d:\projects>cinst
nodejs.install Chocolatey (v0.9.8.20) is installing nodejs.install and
dependencies. By installing you accept the license for nodejs.install
and each dependency you are installing. The schema version of
'Microsoft.AspNet.Mvc' is incompatible with version 2.1.31022.9038 of
NuGet. Please upgrade NuGet to the latest version from
http://go.microsoft.com/fwlink/?LinkId=213942.

Finished installing 'nodejs.install' and dependencies - if errors not
shown in console, none detected. Check log for errors if unsure.

 

The Nu Get version used by Chocolatey itself is out of date.

 

  1. Go to the chocolateyinstall directory
    1. This is normally located in C:\Chocolatey\chocolateyinstall
  2. run nuget update -Self

 

From notes @ Chocolatey: The schema version is incompatible

 

 

Packages I install...

NodeJs
Git
scriptcs

 

(LIST IS INCOMPLETE)

 

 

See Also

PowerShell
Programming.NewSystem
MJP:Blog.2015-02-26